Extension Center

图片说明

RoboForm Lite

By20069129

Version: 2.0.0.0
Size:2035KB
Downloads:7154
Last Updated:2014-10-23 19:51:41

Report Abuse

Screenshots

prev next
  • 图片说明
  • 图片说明

Release note

RoboForm Lite is a free password manager and form filler that automatically remembers your passwords so you'll never have to remember or type your passwords again. Passwords are stored on RoboForm Everywhere server, encrypted.

Features of RoboForm Lite:

- Saves and stores passwords
- Fills forms
- Keeps passwords in sync with other computers and mobile devices
- Password generator

........................................
Ver. 2.0.0 -- October 23, 2014
* One-Time Password support
* Main screen new design
* Form filler algorithm improvements and speed optimization 
* Bug fixing

........................................
Ver. 1.1.0 -- March 24, 2014
* Fix for form filling in Maxthon 4.3.2 
* Fixes and improvements

........................................
Ver. 1.0.2 -- Sept 30, 2013
* Added Chinese, Russian locales
* Bug fixing
  • 20069129 Version:2.0.0.0 2014-10-27 15:28:17 Reply
    I use the paid version of RoboForm and I don't use the cloud feature of RoboForm. This extension can connect through internet to RoboForm server but don't connect to local RoboForm on my PC? It's a so difficult feature to add?

    30655629 2014-08-09 16:37:48

    reply to 30655629: Sorry, you can use only RF Lite which is working with RoboForm Everywhere servers directly.

  • 20069129 Version:2.0.0.0 2014-10-27 14:34:41 Reply

    23 October 2014 version 2.0.0 was submitted to gallery.

  • 20069129 Version:2.0.0.0 2014-10-27 14:32:25 Reply
    ma istallo e mi dice che è pericoloso per la privacy .ma che estensione è? io uso passoword box ,e non mi dice pericoloso istallare .cioè o è sicura o non mettete estensioni dove si viola la privacy

    randagionero 2014-08-24 05:17:29

    reply to randagionero: i dati sono memorizzati su RoboForm Ovunque server, crittografate.

  • 20069129 Version:2.0.0.0 2014-10-27 14:30:14 Reply
    I have mx 4.4.1.2000 browser installed that is the latest. When I try to install this extension, it says, you have mx 2 and at least mx 3 is required, so I couldn't install it. What a silly mistake. Thanks.

    27307888 2014-10-01 22:14:14

    reply to 27307888: Please, try to install RF Lite on latest mx 4.4.1.5000.

  • 27307888 Version:1.1.0 2014-10-01 22:14:14 Reply

    I have mx 4.4.1.2000 browser installed that is the latest. When I try to install this extension, it says, you have mx 2 and at least mx 3 is required, so I couldn't install it. What a silly mistake. Thanks.

Total 24  1/5 12345>

Rate and Review

Give a rating:
Please rating!
500 words left